If Google Maps locations aren't loading on the homepage or search modules even though you already went through the Initial Set Up Steps use the Inspect tool to check which error is being presented inside the Console, it's most likely because the domain name of the site sas changed or it was forgotten while setting up the key, it is simple to go in and fix that error by adding the missing HTTP referrer:



I am using the Inspect tool to check for the error inside the Console while on the page presenting the issue using "CTRL + SHIFT + I" or right click on your mouse:



START HERE:


This can be easily fixed by logging into the Google API Console:


>> https://console.cloud.google.com/apis



Next Steps:


1. Once inside the dashboard select "Credentials"





2. The API key will appear, now click on it:





3. From there add the new HTTP referrer:





Select "ADD AN ITEM", now enter the URL:



Enter the following ones that are missing, one at a time to the "New Item" in the HTTP referrers (web sites) field. 

Press DONE after typing in each domain to add it to the list:


  • *.directoryup.com - this is needed if your site is NOT live yet.

  • *.managemydirectory.com - Important: It is needed in order for your admin pages to work with the maps.

  • managemydirectory.com - Important: It is needed in order for your admin pages to work with the maps.

  • *.ilovebrilliant.com (IMPORTANT: Replace "ilovebrilliant.com" with the final domain that YOUR website will be hosted on)

  • ilovebrilliant.com  (IMPORTANT: Replace "ilovebrilliant.com" with the final domain that YOUR website will be hosted on)


Make sure to save any changes: